第39章 Multi-VPN-Instance CE(MCE)

图片[1]-第39章 Multi-VPN-Instance CE(MCE)-大赛人网
图39-1 Multi-VPN-Instance CE(MCE)配置网络拓扑

1.CE1配置

[CE1]bgp 400
[CE1-bgp]router-id 4.4.4.4
[CE1-bgp]peer 14.1.1.1 as-number 12
[CE1-bgp]import-route direct

2.CE2配置

[CE2]bgp 600
[CE2-bgp]router-id 6.6.6.6
[CE2-bgp]peer 16.1.1.1 as-number 12
[CE2-bgp]import-route direct

3.PE1配置

[PE1]ospf 1 router-id 1.1.1.1
[PE1-ospf-1]area 0
[PE1-ospf-1-area-0.0.0.0]network 1.1.1.1 0.0.0.0
[PE1-ospf-1-area-0.0.0.0]network 12.1.1.0 0.255.255.255

[PE1]ip vpn-instance dsrwa 
[PE1-vpn-instance-dsrwa]route-distinguisher 100:1
[PE1-vpn-instance-dsrwa-af-ipv4]vpn-target 111:1 export-extcommunity
[PE1-vpn-instance-dsrwa-af-ipv4]vpn-target 111:1 import-extcommunity 

[PE1]ip vpn-instance dsrwb
[PE1-vpn-instance-dsrwb]route-distinguisher 100:2
[PE1-vpn-instance-dsrwb-af-ipv4]vpn-target 222:2 export-extcommunity
[PE1-vpn-instance-dsrwb-af-ipv4]vpn-target 222:2 import-extcommunity

[PE1]interface GigabitEthernet 0/0/1
[PE1-GigabitEthernet0/0/1]ip binding vpn-instance dsrwa
[PE1-GigabitEthernet0/0/1]ip address 14.1.1.1 8
[PE1]interface GigabitEthernet 0/0/2
[PE1-GigabitEthernet0/0/2]ip binding vpn-instance dsrwb
[PE1-GigabitEthernet0/0/2]ip address 16.1.1.1 8

[PE1]mpls lsr-id 1.1.1.1
[PE1]mpls
[PE1]mpls ldp
[PE1]interface GigabitEthernet 0/0/0
[PE1-GigabitEthernet0/0/0]mpls
[PE1-GigabitEthernet0/0/0]mpls ldp

[PE1]bgp 12
[PE1-bgp]peer 2.2.2.2 as-number 12
[PE1-bgp]peer 2.2.2.2 connect-interface LoopBack 0
[PE1-bgp]ipv4-family vpn-instance dsrwa
[PE1-bgp-dsrwa]peer 14.1.1.4 as-number 400
[PE1-bgp-dsrwa]import-route direct 
[PE1-bgp]ipv4-family vpn-instance dsrwb
[PE1-bgp-dsrwb]peer 16.1.1.6 as-number 600
[PE1-bgp-dsrwb]import-route direct
[PE1-bgp]ipv4-family vpnv4
[PE1-bgp-af-vpnv4]pe
[PE1-bgp-af-vpnv4]peer 2.2.2.2 enable

4.PE2配置

[PE2]ospf 1 router-id 2.2.2.2
[PE2-ospf-1]area 0
[PE2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0
[PE2-ospf-1-area-0.0.0.0]network 12.1.1.0 0.255.255.255

[PE2]ip vpn-instance dsrwa
[PE2-vpn-instance-dsrwa]route-distinguisher 200:1
[PE2-vpn-instance-dsrwa-af-ipv4]vpn-target 111:1 export-extcommunity 
[PE2-vpn-instance-dsrwa-af-ipv4]vpn-target 111:1 im
[PE2-vpn-instance-dsrwa-af-ipv4]vpn-target 111:1 import-extcommunity
[PE2]ip vpn-instance dsrwb
[PE2-vpn-instance-dsrwb]route-distinguisher 200:2
[PE2-vpn-instance-dsrwb-af-ipv4]vpn-target 222:2 export-extcommunity 
[PE2-vpn-instance-dsrwb-af-ipv4]vpn-target 222:2 im
[PE2-vpn-instance-dsrwb-af-ipv4]vpn-target 222:2 import-extcommunity

[PE2]mpls lsr-id 2.2.2.2
[PE2]mpls
[PE2]mpls ldp
[PE2]interface GigabitEthernet 0/0/0
[PE2-GigabitEthernet0/0/0]mpls
[PE2-GigabitEthernet0/0/0]mpls ldp
[PE2]interface GigabitEthernet 0/0/1.1
[PE2-GigabitEthernet0/0/1.1]ip binding vpn-instance dsrwa
[PE2-GigabitEthernet0/0/1.1]ip address 23.1.1.2 8
[PE2]interface GigabitEthernet 0/0/1.2
[PE2-GigabitEthernet0/0/1.2]ip binding vpn-instance dsrwb
[PE2-GigabitEthernet0/0/1.2]ip address 32.1.1.2 8

[PE2]ospf 100 vpn-instance dsrwa
[PE2-ospf-100]import-route bgp 
[PE2-ospf-100]area 0
[PE2-ospf-100-area-0.0.0.0]network 23.1.1.0 0.255.255.255
[PE2]ospf 200 vpn-instance dsrwb
[PE2-ospf-200]import-route bgp  
[PE2-ospf-200]area 0
[PE2-ospf-200-area-0.0.0.0]network 32.1.1.0 0.255.255.255  

[PE2]bgp 12
[PE2-bgp]peer 1.1.1.1 as-number 12
[PE2-bgp]peer 1.1.1.1 connect-interface LoopBack 0
[PE2-bgp]ipv4-family vpnv4
[PE2-bgp-af-vpnv4]peer 1.1.1.1 enable
[PE2-bgp]ipv4-family vpn-instance dsrwa
[PE2-bgp-dsrwa]import-route ospf 100
[PE2-bgp]ipv4-family vpn-instance dsrwb
[PE2-bgp-dsrwb]import-route ospf 200

5.MCE配置

[MCE]ip vpn-instance dsrwa
[MCE-vpn-instance-dsrwa]route-distinguisher 300:1
[MCE-vpn-instance-dsrwa-af-ipv4]vpn-target 111:1 export-extcommunity 
[MCE-vpn-instance-dsrwa-af-ipv4]vpn-target 111:1 import-extcommunity 
[MCE]ip vpn-instance dsrwb
[MCE-vpn-instance-dsrwb]route-distinguisher 300:2
[MCE-vpn-instance-dsrwb-af-ipv4]vpn-target 222:2 export-extcommunity
[MCE-vpn-instance-dsrwb-af-ipv4]vpn-target 222:2 import-extcommunity
[MCE]interface GigabitEthernet 0/0/0
[MCE-GigabitEthernet0/0/0]ip binding vpn-instance dsrwa
[MCE-GigabitEthernet0/0/0]ip address 35.1.1.3 8
[MCE]interface GigabitEthernet 0/0/2
[MCE-GigabitEthernet0/0/2]ip binding vpn-instance dsrwb
[MCE-GigabitEthernet0/0/2]ip address 37.1.1.3 8
[MCE]interface GigabitEthernet 0/0/1.1
[MCE-GigabitEthernet0/0/1.1]arp broadcast enable
[MCE-GigabitEthernet0/0/1.1]ip binding vpn-instance dsrwa
[MCE-GigabitEthernet0/0/1.1]ip address 23.1.1.3 8
[MCE]interface GigabitEthernet 0/0/1.2
[MCE-GigabitEthernet0/0/1.2]arp broadcast enable
[MCE-GigabitEthernet0/0/1.2]ip binding vpn-instance dsrwb
[MCE-GigabitEthernet0/0/1.2]ip address 32.1.1.3 8 

[MCE]ospf 100 vpn-instance dsrwa
[MCE-ospf-100]import-route rip 100
[MCE-ospf-100]vpn-instance-capability simple 
[MCE-ospf-100]area 0
[MCE-ospf-100-area-0.0.0.0]network 23.1.1.0 0.255.255.255
[MCE]ospf 200 vpn-instance dsrwb
[MCE-ospf-200]import-route rip 200
[MCE-ospf-200]vpn-instance-capability simple 
[MCE-ospf-200]area 0
[MCE-ospf-200-area-0.0.0.0]network 32.1.1.0 0.255.255.255

[MCE]rip 100 vpn-instance dsrwa
[MCE-rip-100]version 2
[MCE-rip-100]network 35.0.0.0
[MCE-rip-100]import-route ospf 100
[MCE]rip 200 vpn-instance dsrwb
[MCE-rip-200]version 2
[MCE-rip-200]network 37.0.0.0 
[MCE-rip-200]import-route ospf 200

6.CE3配置

[CE3]rip 100
[CE3-rip-100]version 2
[CE3-rip-100]network 35.0.0.0
[CE3-rip-100]import-route direct 

7.CE4配置

[CE4]rip 200
[CE4-rip-200]version 2
[CE4-rip-200]network 37.0.0.0 
[CE4-rip-200]import-route direct
© 版权声明
THE END
喜欢就支持一下吧
点赞6 分享
评论 抢沙发
头像
欢迎您留下宝贵的见解!
提交
头像

昵称

取消
昵称

    请登录后查看评论内容